CVE-2018-7851 (140cra312xxx_firmware, bmx/e_cra_firmware, m340_firmware, m580_firmware, modicon_premium_firmware)

CWE-119: Buffer errors vulnerability exists in Modicon M580 with firmware prior to V2.50, Modicon M340 with firmware prior to V3.01, BMxCRA312xx with firmware prior to V2.40, All firmware versions of Modicon Premium and 140CRA312xxx when sending a specially crafted Modbus packet, which could cause a denial of service to the device that would force a restart to restore availability.
Source: NIST
CVE-2018-7851 (140cra312xxx_firmware, bmx/e_cra_firmware, m340_firmware, m580_firmware, modicon_premium_firmware)

Leave a Reply

Your email address will not be published.